Zitatverlinkung in alten, importierten Threads funktioniert nicht.

  • Zitatverlinkung in alten, importierten Threads funktioniert nicht.


    Beschreibung:
    Wenn man bei einer Antwort sich auf einen Beitrag eines anderen Forenteilnehmers bezog und Beitragsteile von ihm zitierte, wurde von der Forensoftware automatisch ein Link eingefügt, der dann zum Beitrag des Zitierenden führte (>Forennick< sagte:...).


    Durch die Übernahme funktionieren diese Zitatlinks in den alten Threads nicht mehr. Entweder man erhält eine Fehlermeldung oder man wird auf die Haupt-/Portalseite des Forums verlinkt.


    Beispiel (fehlerbehaftet) - Link 'Deiddel schrieb:'
    Beispiel (nachträglich korrigiert) - Link 'el Chupa Cabra schrieb:'


    Abgesehen - zwar ärgerlich, dass es sich hierbei um einen Fehler bei der Update-/Übernahmeprozedur handelt, ist die Auswirkung als gering einzuschätzen.
    Antworten werden meist innerhalb von sehr kurzer Zeit gegeben, so dass der Beitrag, auf den man sich bezogen hatte noch auf der selben Forenseite steht (Außnahme Irrenthread, was nun auch nicht sooo elementar ist).


    Beiträge, die nach dem Wechsel der Forensoftware geschrieben wurden, sind davon nicht betroffen.


    @uhle ...fürs Ticket

  • Danke für die Erläuterungen. Ich war kurz nach Umstellung bereits auf das Phänomen gestoßen und hatte mit uhle darüber diskutiert. Leider bin ich dabei zur selben Erkenntnis gelangt.
    Da ich mich bei Recherchen gerne entlang der Zitate rückwärts durch einen Gesprächsfaden hangele, ist das Problem für mich sehr ärgerlich.
    Aber Du hast recht: Das Problem stirbt mit der Zeit von selbst aus. Irgendwann wird der Ärger über "Likes" statt "Danke" überwiegen ;)

  • Die Linkadresse ist ohne genauem Sprungziel definiert, deshalb wird (meist in Forenseiten) die Hauptseite bei nicht finden des Suchziels ausgegeben.


    Entweder man korrigiert den jeweiligen Thread als Admin mit richtiger Adressdeklaration oder man lebt damit.^^


    orginaler Zitatlink: http://www.iggdaw.de/iggdawforum/index.php/Thread/890-Diskussion-Abmahnwahn/?postID=XXXXX#postXXXXX
    fehlerhafter Zitatlink: http://www.iggdaw.de/iggdawforum/index.php?page=Thread&postID=17876#post17876


    Wie man erkennen kann, ist im fehlerhaften Link keine Threadbennung als Ziel fest gelegt. Somit läuft die Suche ins Leere.


    Richtig wäre: http://www.iggdaw.de/iggdawforum/index.php/Thread/890-Diskussion-Abmahnwahn/?page=Thread&postID=17876#post17876


    Mit einer PHP/ SQL-Routine könnte man das beheben. Ist aber etwas Aufwendig.

  • Die letzte Antwort auf dieses Thema liegt mehr als 365 Tage zurück. Das Thema ist womöglich bereits veraltet. Bitte erstelle ggf. ein neues Thema.